adobe flash plugin has failed

Standard

Since some days ago, I began to suffer repeatedly flash plugin crashes, on youtube, vimeo, some flash games… It was very annoying so I investigated the issue on both adobe and mozilla support forums.

There are a lot of threads about that, so I didn’t felt alone in this issue, but it didn’t seem to be a clear solution. In a post somewhere, someone said that perhaps there was installed on the affected system, two versions of the flash plugin, so I did a search into my own system I found only one version. It was the latest one, at the time of write this, is the version 11.2.202.233-1.

So I did a search on AUR and find several versions:

[malevolent@malevolo ~]$ yaourt flash | grep plugin
1 extra/flashplugin 11.2.202.233-1 [installed]
Adobe flash plugin support lib (OSSv4)
provides extra protection for aurora allowing JavaScript, Java and Flash and other plugins to be executed only by trusted web sites of your choice
Official Hulu Desktop client for Linux. You may need to edit ~/.huludesktop to the correct path of your Flash plugin.
Google Chrome's Pepper Flash plugin for Chromium
36 aur/flashplugin-10 10.3.183.18-1 (9)
37 aur/flashplugin-10.1 10.1.102.64-3 (7)
An older version of flashplugin
38 aur/flashplugin-beta 11.2.202.233-1 (473)
39 aur/flashplugin-debugger 11.1.102.63-1 (Out of Date) (17)
40 aur/flashplugin-lahf-fix 0.1-2 (34)
41 aur/flashplugin-prerelease-debug 11.0.1.129-1 (Out of Date) (3)
42 aur/flashplugin-square 10.3.162.29-1 (5)
43 aur/flashplugin_src 11.0.1.152-2 (Out of Date) (6)
GNU flash player and kpath plugin for KDE4
Official Hulu Desktop client for Linux. You may need to edit ~/.huludesktop to the correct path of your Flash plugin.
68 aur/kopete-plugin-thinklight 0.50-2 (8)
This kopete plugin lets a Thinkpad's light flash on every incoming message
69 aur/lib32-flashplugin 11.2.202.233-1 (254)
70 aur/lib32-flashplugin10 10.3.183.15-1 (1)
71 aur/lib32-flashplugin10.1 10.1.102.65-1 (Out of Date) (4)
Open Sound System UNIX audio architecture support for Flash plugin
Adds PulseAudio support to the Flash browser plugin
Macromedia flash plugin support lib (OSS SSL)
Adds PulseAudio support to the Flash browser plugin
92 aur/nspluginwrapper-flash-prerelease 11.2.202.197-1 (Out of Date) (75)
A small application to play, download, rip or convert (to Ogg) videos from popular YouTube-like sites, without the need of the proprietary Flash plugin.

As you can see, there are several versions of the plugin. I’d installed number 37 since I remember with affection that version 😛

So I removed the current version
$ sudo pacman -R flashplugin
And installed flashplugin-10.1 10.1.102.64-3
[adocampo@localhost ~]$ yaourt flashplugin-10
1 aur/flashplugin-10 10.3.183.18-1 (9)
Adobe Flash Player v10 (32-bit) - with GPU hardware acceleration
2 aur/flashplugin-10.1 10.1.102.64-3 (7)
An older version of flashplugin
==> Introduzca el número de los paquetes que se instalarán (ejemplos: 1 2 3 ó 1-3)
==> ------------------------------------------------------------------------------
==> 2

Done!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s