Shutter doesn’t initialize: “Error while opening image ‘sel_window_section.svg”

Standard

Perhaps you installed shutter and its huge list of dependences and thought: “hey, I’m going to shot some captures to make my documentation more cool!” And what’s the bitter surprise when it doesn’t initialize.

Some windows appears saying something weird, like it cannot recognize some image formats…
Well, thanks to ericstone57, a user on AUR community, this can be easyly solved.

As root (not sudo but root), you must reload the loaders.cache

# cd /usr/lib/gdk-pixbuf*/2*
# cp loaders.cache loaders.cache.old
# /usr/bin/gdk-pixbuf-query-loaders > loaders.cache

Buy browsing the networks wondering why those commands, I found a site who reveals a nicer way to do the same by updating the cache of the pixbuf query loaders.

# gdk-pixbuf-query-loaders --update-cache

Advertisements

2 thoughts on “Shutter doesn’t initialize: “Error while opening image ‘sel_window_section.svg”

    • Rich Mack

      Lynn’s fix worked for me too. It also partially solved another issue that I’m having; none of my icons are showing in XFCE4.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s